CentOS7高版本适配低版本包依赖安装

记录一次在centos 7环境下安装部署时,解决由于安装包未适配高版本的系统软件依赖版本导致的安装失败的临时解决方案。

1.需要确保安装的系统配置DNS,可以连上外网。
2.替换当前生效的源为低版本C7.2.1511的源,执行以下命令:

yum install yum-utils
yum-config-manager --disable updates/7/x86_64
yum-config-manager --disable extras/7/x86_64
yum-config-manager --disable base/7/x86_64
yum-config-manager --enable C7.2.1511-base/x86_64
yum-config-manager --enable C7.2.1511-extras/x86_64
yum-config-manager --enable C7.2.1511-updates/x86_64

3.运行安装命令,在安装过程中会根据依赖自动下载安装旧版本的依赖。